import Foundation
let pattern = #"^\/teacher\/(?<id>\d+)\/(?<method>(?:list)|(?:file)|(?:info))(?:(?<=list)$|(?:(?:(?<=file)|(?<=info))\/(?<name>.+$)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"/teacher/1/info/a"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}