$re = '/^\/teacher\/(?<id>\d+)\/(?<method>(?:list)|(?:file)|(?:info))(?:(?<=list)$|(?:(?:(?<=file)|(?<=info))\/(?<name>.+$)))/';
$str = '/teacher/1/info/a';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);