import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s";
final String string = "\n\n"
+ "Description=Qualcomm Atheros AR8161 PCI-E Gigabit Ethernet Controller (NDIS 6.30)\n"
+ "MACAddress=FF:FF:FF:FF:FF:FF\n"
+ "Manufacturer=Qualcomm Atheros\n"
+ "NetConnectionID=Ethernet\n\n\n"
+ "Description=Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter\n"
+ "MACAddress=FF:FF:FF:FF:FF:FF\n"
+ "Manufacturer=Realtek Semiconductor Corp.\n"
+ "NetConnectionID=Wi-Fi\n\n\n"
+ "Description=VirtualBox Host-Only Ethernet Adapter\n"
+ "MACAddress=FF:FF:FF:FF:FF:FF\n"
+ "Manufacturer=Oracle Corporation\n"
+ "NetConnectionID=VirtualBox Host-Only Network\n\n\n"
+ "Description=Bluetooth Device (Personal Area Network)\n"
+ "MACAddress=FF:FF:FF:FF:FF:FF\n"
+ "Manufacturer=Microsoft\n"
+ "NetConnectionID=Connexion réseau Bluetooth 2\n\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}