$re = '/(?:\G(?!\A)|"title":").*?\K"(?=.*?"\s*,\s*"partid":)/m';
$str = '"title":"Гайка 7/16"-14" UNC топорна;14H813;P88344 12"", "partid":"S.4964"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;