import Foundation
let pattern = #"(?:\G(?!\A)|"title":").*?\K"(?=.*?"\s*,\s*"partid":)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #""title":"Гайка 7/16"-14" UNC топорна;14H813;P88344 12"", "partid":"S.4964""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)