using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\d)(?=.*[^\w\s]).{8,}$";
string input = @"Valid passwords:
xkM65!asd
a8jjxa39!af
!r3g3x101!
Tr0ub4dor&3
Invalid passwords:
correcthorsebatterystaple
password
jh81?
starwarsrulez1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}