import re
regex = re.compile(r"^(?=.*\d)(?=.*[^\w\s]).{8,}$", flags=re.MULTILINE)
test_str = ("Valid passwords:\n"
"xkM65!asd\n"
"a8jjxa39!af\n"
"!r3g3x101!\n"
"Tr0ub4dor&3\n\n"
"Invalid passwords:\n"
"correcthorsebatterystaple\n"
"password\n"
"jh81?\n"
"starwarsrulez1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")