re = /^(?=.*\d)(?=.*[^\w\s]).{8,}$/m
str = 'Valid passwords:
xkM65!asd
a8jjxa39!af
!r3g3x101!
Tr0ub4dor&3
Invalid passwords:
correcthorsebatterystaple
password
jh81?
starwarsrulez1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end