#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([\+]?\s?[ 0-9]{1,6}([ \.\-])?)?([\(]{1}[ +0-9]{2,6}[\)])?([ 0-9\.\-]{1,32})([0-9]+))"
Local $sString = "+86-400-660-8680" & @CRLF & _
"+86-400-660-8680" & @CRLF & _
"+1 888 204 3539" & @CRLF & _
"1-800-667-6389" & @CRLF & _
"+1-400-660-8680" & @CRLF & _
"(877) 359-6695" & @CRLF & _
"800-692-7753" & @CRLF & _
"0365987456" & @CRLF & _
"+3342568795" & @CRLF & _
"05987213" & @CRLF & _
"+33 321 82" & @CRLF & _
"efdg ds df +7 (499) 221–62–26 dfs gdsf " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")