import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([\\+]?\\s?[ 0-9]{1,6}([ \\.\\-])?)?([\\(]{1}[ +0-9]{2,6}[\\)])?([ 0-9\\.\\-]{1,32})([0-9]+))";
final String string = "+86-400-660-8680\n"
+ "+86-400-660-8680\n"
+ "+1 888 204 3539\n"
+ "1-800-667-6389\n"
+ "+1-400-660-8680\n"
+ "(877) 359-6695\n"
+ "800-692-7753\n"
+ "0365987456\n"
+ "+3342568795\n"
+ "05987213\n"
+ "+33 321 82\n"
+ "efdg ds df +7 (499) 221–62–26 dfs gdsf \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}