re = /(([\+]?\s?[ 0-9]{1,6}([ \.\-])?)?([\(]{1}[ +0-9]{2,6}[\)])?([ 0-9\.\-]{1,32})([0-9]+))/m
str = '+86-400-660-8680
+86-400-660-8680
+1 888 204 3539
1-800-667-6389
+1-400-660-8680
(877) 359-6695
800-692-7753
0365987456
+3342568795
05987213
+33 321 82
efdg ds df +7 (499) 221–62–26 dfs gdsf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end