#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\n[\h]*@|^[\h]*@)\K([0-9]+)(?=[\s]*\n|[\s]*$)|(?<=[\h\n,]@)([0-9]+)(?=[\h\n,.-]|$)|(?<=[\s,]@|^@)\K([a-zA-ZæøåÆØÅ_0-9]*[a-zA-ZæøåÆØÅ_]+[a-zA-ZæøåÆØÅ_0-9]*+)(?=[\s,]|[-.,:]*[\s]|[-.,:]*$)"
Local $sString = " @ab." & @CRLF & _
"# ^ match at start of string" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# GROUP 1" & @CRLF & _
"@0123456789" & @CRLF & _
"@9412334" & @CRLF & _
" @00000 " & @CRLF & _
"@999" & @CRLF & _
" @123" & @CRLF & _
" @123" & @CRLF & _
"" & @CRLF & _
"# GROUP 2" & @CRLF & _
",@123" & @CRLF & _
"@123,@123,@123" & @CRLF & _
"asdasd,@4782,asdada" & @CRLF & _
"@31, @2312, @1231" & @CRLF & _
"@123 @123 @1234567890" & @CRLF & _
"@123.-, " & @CRLF & _
"@123." & @CRLF & _
"" & @CRLF & _
"# GROUP 3" & @CRLF & _
"@abdefghijklmnopqrstuæøå" & @CRLF & _
"@ABCDEFGÆØÅ" & @CRLF & _
"@123abc" & @CRLF & _
"@abc123" & @CRLF & _
"@123abc123" & @CRLF & _
"@abc." & @CRLF & _
"@abc-" & @CRLF & _
"@abc:" & @CRLF & _
"" & @CRLF & _
"# NO MATCH" & @CRLF & _
"@" & @CRLF & _
".@412" & @CRLF & _
"-@634" & @CRLF & _
"@5234;" & @CRLF & _
"@4234@" & @CRLF & _
"@@1231" & @CRLF & _
"test@example.com" & @CRLF & _
"test@example" & @CRLF & _
"@asd@asd" & @CRLF & _
"asd@as-_d" & @CRLF & _
"@asd.@asd.@asd" & @CRLF & _
"@asd-d " & @CRLF & _
"@ads.com" & @CRLF & _
"@ads-_" & @CRLF & _
"@asd^" & @CRLF & _
"@asdf" & @CRLF & _
"" & @CRLF & _
"Loreæøåm ipasdæøåsumæø dolor sit amet, consectetur adipisicing elit, sed do eiusmod @1234567890 @1 @0 tempor incididunt ut labore @1æøåÆØÅ123et0 dolore magna aliqua. Ut enim ad minim @veniam, @quis @nostrud @123 exercitation ullamco laboris nisi ut aliquip ex ea @commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit æøå esse cillum dolore @asd,@asd,@asd eu fugiat nulla test@example.com pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum. " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# v Match at end of string" & @CRLF & _
"@ab."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")