const regex = /(?:\n[\h]*@|^[\h]*@)\K([0-9]+)(?=[\s]*\n|[\s]*$)|(?<=[\h\n,]@)([0-9]+)(?=[\h\n,.-]|$)|(?<=[\s,]@|^@)\K([a-zA-ZæøåÆØÅ_0-9]*[a-zA-ZæøåÆØÅ_]+[a-zA-ZæøåÆØÅ_0-9]*+)(?=[\s,]|[-.,:]*[\s]|[-.,:]*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\n[\\h]*@|^[\\h]*@)\\K([0-9]+)(?=[\\s]*\\n|[\\s]*$)|(?<=[\\h\\n,]@)([0-9]+)(?=[\\h\\n,.-]|$)|(?<=[\\s,]@|^@)\\K([a-zA-ZæøåÆØÅ_0-9]*[a-zA-ZæøåÆØÅ_]+[a-zA-ZæøåÆØÅ_0-9]*+)(?=[\\s,]|[-.,:]*[\\s]|[-.,:]*$)', 'g')
const str = ` @ab.
# ^ match at start of string
# GROUP 1
@0123456789
@9412334
@00000
@999
@123
@123
# GROUP 2
,@123
@123,@123,@123
asdasd,@4782,asdada
@31, @2312, @1231
@123 @123 @1234567890
@123.-,
@123.
# GROUP 3
@abdefghijklmnopqrstuæøå
@ABCDEFGÆØÅ
@123abc
@abc123
@123abc123
@abc.
@abc-
@abc:
# NO MATCH
@
.@412
-@634
@5234;
@4234@
@@1231
test@example.com
test@example
@asd@asd
asd@as-_d
@asd.@asd.@asd
@asd-d
@ads.com
@ads-_
@asd^
@asdf
Loreæøåm ipasdæøåsumæø dolor sit amet, consectetur adipisicing elit, sed do eiusmod @1234567890 @1 @0 tempor incididunt ut labore @1æøåÆØÅ123et0 dolore magna aliqua. Ut enim ad minim @veniam, @quis @nostrud @123 exercitation ullamco laboris nisi ut aliquip ex ea @commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit æøå esse cillum dolore @asd,@asd,@asd eu fugiat nulla test@example.com pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
# v Match at end of string
@ab.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}