import re
regex = re.compile(r"(?:\n[\h]*@|^[\h]*@)\K([0-9]+)(?=[\s]*\n|[\s]*$)|(?<=[\h\n,]@)([0-9]+)(?=[\h\n,.-]|$)|(?<=[\s,]@|^@)\K([a-zA-ZæøåÆØÅ_0-9]*[a-zA-ZæøåÆØÅ_]+[a-zA-ZæøåÆØÅ_0-9]*+)(?=[\s,]|[-.,:]*[\s]|[-.,:]*$)")
test_str = (" @ab.\n"
"# ^ match at start of string\n\n\n"
"# GROUP 1\n"
"@0123456789\n"
"@9412334\n"
" @00000 \n"
"@999\n"
" @123\n"
" @123\n\n"
"# GROUP 2\n"
",@123\n"
"@123,@123,@123\n"
"asdasd,@4782,asdada\n"
"@31, @2312, @1231\n"
"@123 @123 @1234567890\n"
"@123.-, \n"
"@123.\n\n"
"# GROUP 3\n"
"@abdefghijklmnopqrstuæøå\n"
"@ABCDEFGÆØÅ\n"
"@123abc\n"
"@abc123\n"
"@123abc123\n"
"@abc.\n"
"@abc-\n"
"@abc:\n\n"
"# NO MATCH\n"
"@\n"
".@412\n"
"-@634\n"
"@5234;\n"
"@4234@\n"
"@@1231\n"
"test@example.com\n"
"test@example\n"
"@asd@asd\n"
"asd@as-_d\n"
"@asd.@asd.@asd\n"
"@asd-d \n"
"@ads.com\n"
"@ads-_\n"
"@asd^\n"
"@asdf\n\n"
"Loreæøåm ipasdæøåsumæø dolor sit amet, consectetur adipisicing elit, sed do eiusmod @1234567890 @1 @0 tempor incididunt ut labore @1æøåÆØÅ123et0 dolore magna aliqua. Ut enim ad minim @veniam, @quis @nostrud @123 exercitation ullamco laboris nisi ut aliquip ex ea @commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit æøå esse cillum dolore @asd,@asd,@asd eu fugiat nulla test@example.com pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum. \n\n\n"
"# v Match at end of string\n"
"@ab.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")