package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z!$.&\d]{4,24}[@][a-zA-Z]{2,}(?:\.edu|\.com|\.net)`)
var str = `test@school.edu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}