re = /[a-zA-Z!$.&\d]{4,24}[@][a-zA-Z]{2,}(?:\.edu|\.com|\.net)/
str = 'test@school.edu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end