package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w_.-]{1,}$`)
var str = `sdsd<<sdsdsd/LES-DARKNETS_EXTREMITES-D-UN-RESEAU-AMBIANT_Vincent-Bonnefille_2015_lowdef.pdf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}