re = /[\w_.-]{1,}$/m
str = 'sdsd<<sdsdsd/LES-DARKNETS_EXTREMITES-D-UN-RESEAU-AMBIANT_Vincent-Bonnefille_2015_lowdef.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end