// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\w_.-]{1,}$").unwrap();
let string = "sdsd<<sdsdsd/LES-DARKNETS_EXTREMITES-D-UN-RESEAU-AMBIANT_Vincent-Bonnefille_2015_lowdef.pdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}