using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(?!123|::|[:/]).)*+(?:123|::|[:/]))?\K.+";
string input = @"small_animal/Mouse
BigAnimal:Elephant
Not an animal.
animal::Dog
Another123Cat";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}