$re = '`^(?:(?:(?!123|::|[:/]).)*+(?:123|::|[:/]))?\K.+`m';
$str = 'small_animal/Mouse
BigAnimal:Elephant
Not an animal.
animal::Dog
Another123Cat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);