re = /^(?:(?:(?!123|::|[:\/]).)*+(?:123|::|[:\/]))?\K.+/m
str = 'small_animal/Mouse
BigAnimal:Elephant
Not an animal.
animal::Dog
Another123Cat'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end