import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^((?'isolated_keywords'('none')|(deny))|((?'single'(?'just_scheme'[a-z]+\\:)|(?'uri'(?'scheme'[a-z]+\\:(?'scheme_separator'\\/\\/)?)?(?'host'[a-z0-9\\-*]+\\.[a-z0-9\\-*.]+)(?'port':[0-9*]+)?)|('self')|(sameorigin))(?'list'((?'list_separator'\\ )(?'list_content'(?'just_scheme_in_list'[a-z]+\\:)|(?'uri_in_list'(?'scheme_in_list'[a-z]+\\:(?'scheme_separator_in_list'\\/\\/)?)?(?'host_in_list'[a-z0-9\\-*]+\\.[a-z0-9\\-*.]+)?(?'port_in_list':[0-9*]+)?)))+)?))$";
        final String string = "'self'\n"
	 + "sameorigin plus.some.host\n\n";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}