import re
regex = re.compile(r"^((?'isolated_keywords'('none')|(deny))|((?'single'(?'just_scheme'[a-z]+\:)|(?'uri'(?'scheme'[a-z]+\:(?'scheme_separator'\/\/)?)?(?'host'[a-z0-9\-*]+\.[a-z0-9\-*.]+)(?'port':[0-9*]+)?)|('self')|(sameorigin))(?'list'((?'list_separator'\ )(?'list_content'(?'just_scheme_in_list'[a-z]+\:)|(?'uri_in_list'(?'scheme_in_list'[a-z]+\:(?'scheme_separator_in_list'\/\/)?)?(?'host_in_list'[a-z0-9\-*]+\.[a-z0-9\-*.]+)?(?'port_in_list':[0-9*]+)?)))+)?))$", flags=re.MULTILINE)
test_str = ("'self'\n"
"sameorigin plus.some.host\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")