import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "VARIABLE[^V]*(?:V(?!ARIABLE)[^V]*)*";
final String string = "VARIABLE: GRP1.SGRP1.100:VAR1\n\n"
+ "Timestamp (LOCAL_TIME),Value\n"
+ "2018-07-18 13:52:09.100,25582\n"
+ "2018-07-18 13:52:49.900,24048\n"
+ "VARIABLE: GRP1.SGRP2.102:VAR1\n\n"
+ "Timestamp (LOCAL_TIME),Value\n"
+ "2018-07-18 13:52:09.100,25582\n"
+ "2018-07-18 13:52:49.900,24048";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}