# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"VARIABLE[^V]*(?:V(?!ARIABLE)[^V]*)*"
test_str = ("VARIABLE: GRP1.SGRP1.100:VAR1\n\n"
"Timestamp (LOCAL_TIME),Value\n"
"2018-07-18 13:52:09.100,25582\n"
"2018-07-18 13:52:49.900,24048\n"
"VARIABLE: GRP1.SGRP2.102:VAR1\n\n"
"Timestamp (LOCAL_TIME),Value\n"
"2018-07-18 13:52:09.100,25582\n"
"2018-07-18 13:52:49.900,24048")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.