re = /VARIABLE[^V]*(?:V(?!ARIABLE)[^V]*)*/m
str = 'VARIABLE: GRP1.SGRP1.100:VAR1
Timestamp (LOCAL_TIME),Value
2018-07-18 13:52:09.100,25582
2018-07-18 13:52:49.900,24048
VARIABLE: GRP1.SGRP2.102:VAR1
Timestamp (LOCAL_TIME),Value
2018-07-18 13:52:09.100,25582
2018-07-18 13:52:49.900,24048'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end