#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(> \[!anki]- .+(?:\n[>^].*)*)(?:\n<!-- end of flashcard -->)?"
Local $sString = "> [!anki]- Title" & @CRLF & _
"> Answer" & @CRLF & _
"" & @CRLF & _
"> [!anki]- Title" & @CRLF & _
"> Answer" & @CRLF & _
"<!-- end of flashcard -->" & @CRLF & _
"" & @CRLF & _
"> [!anki]- Title" & @CRLF & _
"> Answer" & @CRLF & _
"> Another line" & @CRLF & _
"> Another line" & @CRLF & _
"" & @CRLF & _
"> [!anki]- Title" & @CRLF & _
"> Answer" & @CRLF & _
"^7a6a36"
Local $sSubst = "$1\n<!-- end of flashcard -->"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)