$re = '/(> \[!anki]- .+(?:\n[>^].*)*)(?:\n<!-- end of flashcard -->)?/';
$str = '> [!anki]- Title
> Answer
> [!anki]- Title
> Answer
<!-- end of flashcard -->
> [!anki]- Title
> Answer
> Another line
> Another line
> [!anki]- Title
> Answer
^7a6a36';
$subst = "$1\n<!-- end of flashcard -->";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;