using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(> \[!anki]- .+(?:\n[>^].*)*)(?:\n<!-- end of flashcard -->)?";
string substitution = @"$1\n<!-- end of flashcard -->";
string input = @"> [!anki]- Title
> Answer
> [!anki]- Title
> Answer
<!-- end of flashcard -->
> [!anki]- Title
> Answer
> Another line
> Another line
> [!anki]- Title
> Answer
^7a6a36";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}