$re = '/-{9,}\W*((?:(?!-{9}).)*?)- \[\d+]/m';
$str = '---------Some text is here.---------More text is here - [3548]----- Even more text is here.-----------More text is here - [408]--------- Even more text is here again.';
$subst = " \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;