package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ab(?:[^a]|a[^ab])*?a*cd`)
var str = `start ab0 ab1 aabcd kkkk cd
start ab0 ab1 aabacd kkkk cd
start ab0 ab1 aab2 cd kkkk cd
start ab0 ab1 aab2 aacd kkkk cd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}