const regex = /ab(?:[^a]|a[^ab])*?a*cd/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ab(?:[^a]|a[^ab])*?a*cd', 'g')
const str = `start ab0 ab1 aabcd kkkk cd
start ab0 ab1 aabacd kkkk cd
start ab0 ab1 aab2 cd kkkk cd
start ab0 ab1 aab2 aacd kkkk cd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}