$re = '/ab(?:[^a]|a[^ab])*?a*cd/';
$str = 'start ab0 ab1 aabcd kkkk cd
start ab0 ab1 aabacd kkkk cd
start ab0 ab1 aab2 cd kkkk cd
start ab0 ab1 aab2 aacd kkkk cd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);