package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_(\d+)`)
var str = `C_3H_5N_3O_9) (4 \times 10^{25}) J`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}