$re = '/_(\d+)/m';
$str = 'C_3H_5N_3O_9) (4 \\times 10^{25}) J';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);