const regex = /_(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_(\\d+)', 'gm')
const str = `C_3H_5N_3O_9) (4 \\times 10^{25}) J`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}