#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\D{3}.\d{2}.\d{4}).*(?<=\D)"
Local $sString = "I N V O I C E **** JUL.19,2022" & @CRLF & _
"D A T E :" & @CRLF & _
"1-21, SHIBAURA 3-CHOME,MINATO-KU,TOKYO, JAPAN" & @CRLF & _
"NN390" & @CRLF & _
"INVOICE NO." & @CRLF & _
"MITSUBISHI MOTORS AUSTRALIA LIMITED." & @CRLF & _
"1 SIR RICHARD WILLIAMS AVENUE," & @CRLF & _
"ADELAIDE AIRPORT SA 5950 AUSTRALIA" & @CRLF & _
"NAME OF VESSEL ON OR ABOUT LOADING PORT" & @CRLF & _
"OOCL NEW ZEALAND 115S JUL.30,2022 NAGOYA,JAPAN" & @CRLF & _
"DISCHARGING PORT INSURANCE" & @CRLF & _
"FREMANTLE,AUSTRALIA" & @CRLF & _
"COVERED BY SHIPPER" & @CRLF & _
"PAYMENT TERMS" & @CRLF & _
"REMITTANCE AT 45 DAYS AFTER B/L DATE" & @CRLF & _
"MARK & NOS DESCRIPTION QUANTITY UNIT PRICE AMOUNT" & @CRLF & _
"-AS PER SPARE PARTS FOR" & @CRLF & _
"ATTACHED SHEET- MITSUBISHI VEHICLES" & @CRLF & _
"PCS AUS.DOLLARS" & @CRLF & _
"*** ***********" & @CRLF & _
"FOB NET 2,553 75,622.32*" & @CRLF & _
"PACKING CHARGE 529.36*" & @CRLF & _
"FOB NAGOYA JAPAN 76,151.68*" & @CRLF & _
"INSURANCE 380.76*" & @CRLF & _
"C&I FREMANTLE 76,532.44*" & @CRLF & _
"**********" & @CRLF & _
""WE DECLARE THAT THE MACHINERY AND/OR PARTS AND" & @CRLF & _
"ACCESSORIES ARE NEW AND UNUSED AND HAVE NOT BEEN FIELD" & @CRLF & _
"TESTED OR FACTORY TRIALLED"" & @CRLF & _
"PACKING LIST" & @CRLF & _
"LOT NO C/S NO GROSS WT NET WT M/M" & @CRLF & _
"MASAYUKI SHIBUYA GENERAL MANAGER" & @CRLF & _
"GLOBAL AFTER SALES LOGISTICS DEPARTMENT" & @CRLF & _
"GLOBAL AFTER SALES DIVISION" & @CRLF & _
"MITSUBISHI MOTORS CORPORATION" & @CRLF & _
"AV 0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")