import re
regex = re.compile(r"(?<=\D{3}.\d{2}.\d{4}).*(?<=\D)", flags=re.MULTILINE)
test_str = ("I N V O I C E **** JUL.19,2022\n"
"D A T E :\n"
"1-21, SHIBAURA 3-CHOME,MINATO-KU,TOKYO, JAPAN\n"
"NN390\n"
"INVOICE NO.\n"
"MITSUBISHI MOTORS AUSTRALIA LIMITED.\n"
"1 SIR RICHARD WILLIAMS AVENUE,\n"
"ADELAIDE AIRPORT SA 5950 AUSTRALIA\n"
"NAME OF VESSEL ON OR ABOUT LOADING PORT\n"
"OOCL NEW ZEALAND 115S JUL.30,2022 NAGOYA,JAPAN\n"
"DISCHARGING PORT INSURANCE\n"
"FREMANTLE,AUSTRALIA\n"
"COVERED BY SHIPPER\n"
"PAYMENT TERMS\n"
"REMITTANCE AT 45 DAYS AFTER B/L DATE\n"
"MARK & NOS DESCRIPTION QUANTITY UNIT PRICE AMOUNT\n"
"-AS PER SPARE PARTS FOR\n"
"ATTACHED SHEET- MITSUBISHI VEHICLES\n"
"PCS AUS.DOLLARS\n"
"*** ***********\n"
"FOB NET 2,553 75,622.32*\n"
"PACKING CHARGE 529.36*\n"
"FOB NAGOYA JAPAN 76,151.68*\n"
"INSURANCE 380.76*\n"
"C&I FREMANTLE 76,532.44*\n"
"**********\n"
"\"WE DECLARE THAT THE MACHINERY AND/OR PARTS AND\n"
"ACCESSORIES ARE NEW AND UNUSED AND HAVE NOT BEEN FIELD\n"
"TESTED OR FACTORY TRIALLED\"\n"
"PACKING LIST\n"
"LOT NO C/S NO GROSS WT NET WT M/M\n"
"MASAYUKI SHIBUYA GENERAL MANAGER\n"
"GLOBAL AFTER SALES LOGISTICS DEPARTMENT\n"
"GLOBAL AFTER SALES DIVISION\n"
"MITSUBISHI MOTORS CORPORATION\n"
"AV 0\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")