import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\D{3}.\\d{2}.\\d{4}).*(?<=\\D)";
final String string = "I N V O I C E **** JUL.19,2022\n"
+ "D A T E :\n"
+ "1-21, SHIBAURA 3-CHOME,MINATO-KU,TOKYO, JAPAN\n"
+ "NN390\n"
+ "INVOICE NO.\n"
+ "MITSUBISHI MOTORS AUSTRALIA LIMITED.\n"
+ "1 SIR RICHARD WILLIAMS AVENUE,\n"
+ "ADELAIDE AIRPORT SA 5950 AUSTRALIA\n"
+ "NAME OF VESSEL ON OR ABOUT LOADING PORT\n"
+ "OOCL NEW ZEALAND 115S JUL.30,2022 NAGOYA,JAPAN\n"
+ "DISCHARGING PORT INSURANCE\n"
+ "FREMANTLE,AUSTRALIA\n"
+ "COVERED BY SHIPPER\n"
+ "PAYMENT TERMS\n"
+ "REMITTANCE AT 45 DAYS AFTER B/L DATE\n"
+ "MARK & NOS DESCRIPTION QUANTITY UNIT PRICE AMOUNT\n"
+ "-AS PER SPARE PARTS FOR\n"
+ "ATTACHED SHEET- MITSUBISHI VEHICLES\n"
+ "PCS AUS.DOLLARS\n"
+ "*** ***********\n"
+ "FOB NET 2,553 75,622.32*\n"
+ "PACKING CHARGE 529.36*\n"
+ "FOB NAGOYA JAPAN 76,151.68*\n"
+ "INSURANCE 380.76*\n"
+ "C&I FREMANTLE 76,532.44*\n"
+ "**********\n"
+ "\"WE DECLARE THAT THE MACHINERY AND/OR PARTS AND\n"
+ "ACCESSORIES ARE NEW AND UNUSED AND HAVE NOT BEEN FIELD\n"
+ "TESTED OR FACTORY TRIALLED\"\n"
+ "PACKING LIST\n"
+ "LOT NO C/S NO GROSS WT NET WT M/M\n"
+ "MASAYUKI SHIBUYA GENERAL MANAGER\n"
+ "GLOBAL AFTER SALES LOGISTICS DEPARTMENT\n"
+ "GLOBAL AFTER SALES DIVISION\n"
+ "MITSUBISHI MOTORS CORPORATION\n"
+ "AV 0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}