#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9]+(?:\.[a-zA-Z0-9]+)*@[a-zA-Z0-9]+(?:\.[a-zA-Z0-9]+)*$"
Local $sString = "firstname@gmail.com" & @CRLF & _
"firstname.@gmail.com" & @CRLF & _
"firstname..lastname@gmail.com" & @CRLF & _
"firstname#lastname@gmail.com" & @CRLF & _
"frist1991@gmail.com" & @CRLF & _
"first name@gmai.com" & @CRLF & _
".fristname@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")