package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]+(?:\.[a-zA-Z0-9]+)*@[a-zA-Z0-9]+(?:\.[a-zA-Z0-9]+)*$`)
var str = `firstname@gmail.com
firstname.@gmail.com
firstname..lastname@gmail.com
firstname#lastname@gmail.com
frist1991@gmail.com
first name@gmai.com
.fristname@gmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}