$re = '/^[a-zA-Z0-9]+(?:\.[a-zA-Z0-9]+)*@[a-zA-Z0-9]+(?:\.[a-zA-Z0-9]+)*$/m';
$str = 'firstname@gmail.com
firstname.@gmail.com
firstname..lastname@gmail.com
firstname#lastname@gmail.com
frist1991@gmail.com
first name@gmai.com
.fristname@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);