$re = '/(\..+?,)+/';
$str = '1805161703530.jpg,1805161703531.jpg,1805161703532.jpg,';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);