$re = '/(?!^foo$)^\w+$/m';
$str = 'foo
foobar
food
like
many
times
fun
plan
things
stuff
wins
foo
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);