re = /(?!^foo$)^\w+$/m
str = 'foo
foobar
food
like
many
times
fun
plan
things
stuff
wins
foo
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end