#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*[()!=<>", ])(?!(?:first|second|third)$).+$"
Local $sString = "first" & @CRLF & _
"second" & @CRLF & _
"1first" & @CRLF & _
"first1" & @CRLF & _
"1first1" & @CRLF & _
"fou rth" & @CRLF & _
"newTest" & @CRLF & _
"new(test" & @CRLF & _
" " & @CRLF & _
"space word"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")