import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*[()!=<>\", ])(?!(?:first|second|third)$).+$";
final String string = "first\n"
+ "second\n"
+ "1first\n"
+ "first1\n"
+ "1first1\n"
+ "fou rth\n"
+ "newTest\n"
+ "new(test\n"
+ " \n"
+ "space word";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}