import re
regex = re.compile(r"^(?!.*event2\b).*$", flags=re.MULTILINE)
test_str = ("event23,event1,event67=12\n"
"event1,event30\n"
"event23\n"
"event2\n"
"event2\n"
"event2,event23")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")