re = /^(?!.*event2\b).*$/m
str = 'event23,event1,event67=12
event1,event30
event23
event2
event2
event2,event23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end